软件简介

minipad2 是一款小巧的纯文本笔记软件，系统资源占用少，集笔记/便笺、计算器、备忘录、电子词典、快启面板、通讯录、文字模板、多重剪贴板等多种功能于一体，所有内容自动保存，关闭时自动记忆最后的状态。

软件可在多标签页便笺风格与带导航树的笔记风格之间自由切换。不用时可隐藏到桌面边缘，或最小化到系统托盘。

软件提供了非常灵活的选项配置，各项扩展功能类似于插件，可自由选择是否启用。

minipad2 为单文件纯绿色软件，解压至任意文件夹下即可使用，除了设为随系统启动的场合往注册表中添加一键值外，其他场合不写任何注册表。

minipad2 是免费软件，您可以任意使用、复制、分发和传播该软件，但请保证安装包与程序本身的完整性，未经作者许可不得随意修改程序或捆绑插件，且不得基于任何商业目的捆绑销售。

作者提供对软件的免费的 Email 与 论坛 技术支持。

软件主页：http://www.nebulasoft.cn

中文论坛：http://www.nebulasoft.cn/bbs

英文论坛：http://www.nebulasoft.cn/forum

minipad2 的当前版本为 3.2 beta3，最后更新于 2010.5.26.

本帮助文档基于 3.2 beta3 编写，最后更新于 2010.5.26.


版本历史

  1. 3.2 版更新历史
  2. 3.1 版更新历史
  3. 3.0 版更新历史
  4. 2.x 版更新历史


3.2 版

3.2 版更新历史

3.2.0 build 101003 .. 101128

  1. 再次调整了笔记小窗口的设计。省去了标题框，用@xxx代替标题
  2. 支持对各菜单条目快捷键的自定义
  3. 新选项：记忆页面滚动位置；树窗口位于右侧；分隔条宽度；关闭笔记热键、自动记录开关热键；剪贴板：过滤所有重复条目；
  4. 选项对话框中增加应用按钮
  5. 全局搜索增加“区分大小写”选项
  6. 文字工具增加删除空行、只空一行
  7. 丰富了字数统计的项目。
  8. Alt+Up, Alt+Down: 用于上、下移动所选项目（当列表窗口处于焦点时。仅支持单选），或在同一层次上向上、向下移动节点（当树窗口处于焦点时）。
  9. 升级了 3.1 版的各语言文件。
  10. 修正了一些 bug

3.2 beta5 build 100818

  1. 列表设定增加“应用到全部”按钮
  2. 支持摘要视图的字体与背景色设置
  3. 支持“新建笔记”小窗口的字体与背景色设置
  4. 备忘录加入年循环
  5. 剪贴板支持固定条目
  6. 快速链接与文字模板：加入在弹出菜单情况下用于快速存取某一项目的“缩写”项（模仿 win+r 风格）
  7. 文字模板新增 %c(##) 转义符，可用于打出任意的 ASCII 字符，包括不可见字符（适合于直接打出下划线高亮）
  8. 导出方式增加导出到剪贴板
  9. 在导入导出过程中，按住 Esc 可终止操作
  10. 其他小的改进、修复与性能优化

3.2 beta4 build 100718

  1. “插入链接”支持相对路径
  2. 计算器新增 int(x)（取整）, \(整除), !（取余）, round(x,y)（x 精确到 y 位小数）四个操作符／函数
  3. 列表的自定义支持拖放
  4. 恢复了“自动记录”功能
  5. ctrl_Left 向左隐藏／恢复树窗口，crl_Right 向右隐藏／恢复树窗口
  6. 全局搜索结果增加“节点路径”项目
  7. 新的 Ini 选项：定时提醒的默认时间
  8. 改进了托盘区“新建笔记”模块的设计，并可同时创建多个新笔记
  9. 其他小的改进和 bug修复

3.2 beta3 build 100526

  1. 更新了中英帮助文件。
  2. 一些小的改进与较多的 bug 修复。

3.2 beta2 build 100506

  1. 更新了英文语言文件。
  2. 新增了捕捉文字并保存为文件的功能。
  3. 完善了“插入链接”对话框；支持内部的节点链接。
  4. 较多的新选项、小的改进与 bug 修复。

3.2 beta1 build 100418

  1. 修改了局部文字高亮的设计。配色方案增加到4种，除下划线外还支持背景色。
  2. 修改了密码登录的设计。可设定托盘区锁定时间，可对原始的数据库文件进行加密。
  3. 重写了文件 I/O 的基础类，对于逐行读取大大提高了执行效率。
  4. 相比 alpha 的大量的 bug 修正与小的改进。

3.2 alpha build 100401

本版相对于 3.1.6 版的更新：

  1. 核心代码的完全重写与数据存储结构的重新设计。
  2. 菜单项目的重新整合。
  3. “属性”对话框，整合了与页相关的各种属性设置。添加了时间戳、外部图标、外部存储文件、备注等相关属性。
  4. 为列表类型的页增加了“摘要”视图。
  5. 任意一个笔记页均可选择是将数据存储于数据库文件中、还是存于独立的外部文本文件中。导入与文件拖入均支持外部存储方式。这使得 minipad2 可作为大量文本文件或电子书的树状结构的虚拟管理器使用，而无需将所有文本存储于单一的数据库中，大大分散了数据存取风险，提高了数据载入效率。
  6. 笔记导出支持 ANSI 等非 Unicode 编码方式。
  7. 系列“文字工具”：包括为文字添加下划线，以及添加列表符。
  8. 查找／替换功能的增强：支持在选区内查找，支持高亮查找结果。支持反向查找与替换。
  9. “插入链接”对话框，方便在笔记中插入文件链接。
  10. 取消“自动记录”功能，改为以全快捷键方式进行操作的“笔记摘录”功能。
  11. 增加“最近的笔记“导航项，包含最近创建、最近修改、最近访问三类。方便查找与切换到最近的笔记。
  12. 增加收藏夹功能。
  13. 增加全局搜索功能，可根据特定的标题、内容文字等进行搜索，列出所有匹配项目。
  14. 增加回收站功能。
  15. 简化了快速链接的设计。新版中的快速链接除了可以弹出菜单的形式显示以外，与普通链接页并无区别。
  16. 以列表形式进行剪贴板项目管理。剪贴板项目同样支持新建、编辑、删除等操作。
  17. 列表项目可显示勾选框（对于作为 to-do-list 使用的备忘页面较为有用）。部分列表项目（如联系人）支持独立的图标设置。
  18. 新增“统计信息”菜单项。不仅可对当前页面的文字进行统计，且可对整个数据库中各类页面的数量进行统计。
  19. “自定义工具栏”对话框中支持拖放操作。
  20. 完善了备份机制。可进行多重备份、可选择是定时备份、还是按一定的保存次数进行备份。
  21. 大量的新选项与其他小的改进。


3.1 版

3.1 版更新历史

3.1.6 build 090919 ～ build 091012

  1. 词典页加入屏幕取词功能。
  2. 在笔记页中按 F10 将当前所选文字作为页面标题。
  3. 若干细节性改进与 bug 修复。
  4. 帮助文档加入索引与搜索功能。

3.1.5 build 090907

  1. 导入操作：支持从资源管理器中直接拖入文件或文件夹。
  2. 完善了整组的导入导出功能。现支持整组导出成文件夹, 以及整组从文件夹导入，两种操作均保留树结构。
  3. 按住 Ctrl 再点击“新建”，新建的节点将插入在当前节点之前。
  4. 改善了当从其它软件切换回 minipad2 时编辑区的焦点问题。
  5. 使用 Ctrl+Tab 可在编辑区与树／标签区之间切换焦点。
  6. 列表窗口：支持单击列头进行升／降排序，支持列头拖放以调整各列的顺序。
  7. 可设定用于发送邮件的邮件客户端程序。
  8. 计算页：支持百分号、中括号、大括号。（后两者将自动替换为小括号）
  9. 计算页：支持按 F9 进行整页重计算。
  10. 备忘页：弹出提醒框中新增“不再提醒”与“关闭后删除”选项。
  11. 文字模板：日期／时间格式自动遵从区域选项中设置, 并可自定义 %u(###)
  12. 文字模板：新增用于将任意编辑器中的选中文字添加到 minipad2 模板列表的快捷键设置。
  13. 链接页：支持从外部（桌面、资源管理器...）拖入链接。
  14. 调整了各对话框中的条目尺寸，修正了在 French、Spanish 等语言下对话框中条目文字显示不完整的问题。
  15. 其它小的完善性工作与 bug 修正。

3.1.4 build 090801

  1. 支持整组的导出与删除。
  2. 加入全局查找功能。
  3. 加入密码登录功能。

3.1.3 build 090724

  1. 完善了多语言支持，允许以外置 lng 文件的形式将软件翻译为除中英双语以外的其它语言。
  2. 完成了英文帮助文档。
  3. 加入了新选项：切换页面时焦点自动在编辑器。
  4. 对计算器、备忘录与文字模板作了少量的完善与增强。
  5. 一些小的完善与 bug 修正。

3.1.2 build 090707

  1. 修复了边缘隐藏时不停保存文件与无法重命名的 bug！
  2. 修复了调整窗口大小时闪烁的问题。
  3. 修复了当前行高亮下有时无法输入中文字符的 bug。
  4. 当窗口从边缘隐藏状态恢复时，编辑区自动获得输入焦点。
  5. 允许指定程序启动时载入的页面。
  6. 对中文帮助文档进行了 Html 重制作与编译。
  7. 一些小的完善与 bug 修正。

3.1.1 build 090630

  1. 编辑区块状文字选择后，支持使用 Tab 与 Shift_Tab 调整缩进。
  2. 编辑器中的链接可用 Ctrl_Enter 打开。
  3. 加入了 2.x 版的“记忆导出文件”选项。
  4. 加入多项树窗口的界面选项：显示水平滚动条、显示节点按钮、显示节点连线、根节点以线相连。
  5. 树窗口与标签栏均可选择是否显示图标。
  6. 在树窗口与编辑区的分隔条上增加了隐藏树窗口的按钮。
  7. 第一次启动时自动生成三项默认文字模板：插入日期、插入时间、插入日期时间
  8. 文字模板支持 Tab 与 Enter 的模拟按键，可用于自动填表。
  9. 剪贴板新增选项：弹出菜单宽度、弹出菜单无焦点、粘贴项目上浮到第一项
  10. 为文字模板、剪贴板与快速链接的弹出菜单增加了 ToolTip 提示。
  11. 剪贴板弹出菜单支持 Shift + 单击的合并粘贴。
  12. 加入“自动记录”功能，方便将 minipad2 作为资料收集面板。
  13. 备忘条目的提示音细分为 PC 发声与 wav 文件两种。
  14. 其它的一些细节性的完善与 bug 修复。

3.1.0 build 090614

  1. 加入了手动保存功能。
  2. 增强了剪贴板功能的稳定性。
  3. 修复了一些 bug。
  4. 完成了中文帮助文档。

3.1 beta5 build 090606

  1. 加入了“标签位于底部”选项。
  2. 加入了“操作习惯”系列选项。
  3. 加入了字数统计功能。
  4. 解决了编辑器文字与行号在某些字体下错位的 bug，以及在字体缩放时行号与文字会发生错位的 bug。
  5. 修改了自动备份的设计。原设计基于每隔若干小时进行备份，现设计为每隔若干次保存进行一次备份。
  6. 进一步完善了功能，修复了若干 bug。

3.1 beta4 build 090531

  1. 完善了拖曳支持。现支持标签页/组-->标签页/组（改变节点位置）、列表条目-->标签页（改变条目所属页面）、列表条目-->列表条目（改变条目排序）三种类型的拖曳。普通拖曳为移动，Ctrl+拖曳则为复制。
  2. 进一步完善了功能，修复了若干 bug。

3.1 beta3 build 090524

  1. 修复了较多的 bug，提高了软件稳定性。
  2. 修正了在非中文字体（如 Arial）下载入大文本时接近假死的问题。
  3. 加入了 3.0 版的“查看剪贴文字”功能。
  4. 为每一页面记忆光标所在位置，在载入页面时自动恢复。
  5. 计算页加入了 log(x,y) 内置函数（以 x 为底的 y 的对数）。

3.1 beta2 build 090520

  1. 基本修正了自 beta1 发布以来几天内发现的一些 bug。
  2. 增加了“外部滚动”选项。

3.1 beta1 build 090515

  1. 在 3.1 alpha 的基础上集成了 3.0 版的各种扩展功能。

3.1 alpha build 090421

本版相对于 3.0 版的更新：

  1. 源代码的大幅度结构调整与重写。
  2. 增加了对任意层目录的支持。增加“前一页”、“后一页”、“上一层”等导航操作。
  3. 增加了拖曳改变节点位置的功能。删除了不再有意义的“左移”、“右移”、“项目上移”、“项目下移”等按钮。
  4. 改变了数据存储结构。现为一对 idx + dat 的搭配。
  5. 计算器模块的重写与功能增强。现支持自定义函数与变量，支持注释。
  6. 集成了 2.3.2 版的“自动调整界面元素”功能。当缩小窗口时各界面元素会自动依次隐藏。
  7. 加入了高亮当前行选项。
  8. 查找与替换文字的输入增加下拉框，自动记忆历史记录。
  9. 增加了直接切换透明效果的菜单项。
  10. 参照 2.3.2 版设计，各扩展功能类似于插件，可在选项中选择是否启用。


3.0 版

3.0 版更新历史

内核上的更新：

  1. 使用 Object Pascal / Win32 SDK 自行搭建 XCL 类库，在此基础之上构建 3.x 版。大大缩小了程序体积，提高了运行效率。
  2. 100% Unicode 内核，彻底根除乱码问题。
  3. 使用 RichEdit 代替 Edit 作为核心编辑控件，使用流式输入输出，极大地提高了编辑器的性能与对大文本的处理速度，且内置支持 OLE 拖曳、链接高亮、几乎无限次的撤销与恢复等新特性。
  4. 全新设计的数据存储结构，使用带索引的二进制块状文本读写取代原有的逐行读写与判断，极大地提高了数据存取效率。

功能上的更新日志：

final (2009-3-19)

  1. 行号选项
  2. 页边距选项
  3. 编辑器支持“追加”模式
  4. 增加了定时备份的选项
  5. 新增工具窗口风格（无任务栏按钮）、窗体透明度等选项
  6. 计算页新增角度弧度转换函数（deg、rad）
  7. 修正了几个小问题

alpha4 (2008-12-5)

  1. 加入集定时提醒、计划任务与日程管理功能于一身的备忘录功能。
  2. 集成 2.x 版的词典功能。
  3. 加入 2.x 版的自动隐藏功能。
  4. 文字内的超链接支持高亮特性。双击调用链接。
  5. 众多的其他小的改进。

alpha3 (2008-11-1)

  1. 集成2.3.2版的文字模板功能。
  2. 加入链接页（快启面板）、通讯录两项新功能。
  3. 支持标签页的跨组移动。
  4. 树窗口、列表窗口均可独立设置字体与背景色。
  5. 其他小的改进与bug修正。

alpha2 （2008-9-28）

  1. 集成 2.x 版的剪贴板监视。
  2. 三角函数支持角度制计算。支持 pi、e 两个常数（如 sin(e)+2+pi 是合法的）。支持在便笺页中的嵌入式计算。
  3. 众多小的改进，以及选项的细化。

alpha1（2008-9-14）

  1. 实现标签分组功能。支持任意多组标签，提供组之间的切换。
  2. 可在多页面标签风格与带树窗口的笔记风格之间进行切换。


2.x 版

2.x 版更新历史
（1.0 ... 2.3.2）

2.3.0 ~ 2.3.2 （2007.12.2. ~ 2008.4.22.）

  1. 重写了 90% 以上的源代码。
  2. 新增剪贴板增强功能。可在任何Windows编辑软件中调用。
  3. 新增插入模板文字功能。可在任何Windows编辑软件中调用。
  4. 删除桌面贴模式，改为“自动回卷”与“自动隐藏于桌面边缘”两种特效模式。
  5. 备忘提醒支持当天、每周（某几天）、每月（某几天）、每天四类设定。增加提醒窗口的动画弹出效果，增强了提醒窗口“总在最前”的稳定性。
  6. 增加标签页切换的菜单项与工具栏按钮。
  7. 新增“发送邮件”功能项，可以电子邮件形式发送便笺内容。
  8. 增加“显示菜单栏”与“自动调整界面”选项。
  9. 自定义工具栏。
  10. 支持右键菜单操作。
  11. 增强的撤销功能，支持清空与文字替换操作的撤销。
  12. 新增“备份中心”功能，允许恢复最近一次删除的标签页，并可查看最近两次的备份文件。
  13. 众多的细节性改进与bug修正。

2.2.0 ~ 2.2.1 （2007.9.23. ~ 9.26.）

  1. 增加“新建词典页”功能，支持自定义词典列表。
  2. 增加拖放支持，支持从其他编辑器或IE中选中文字后以拖放形式复制或剪切到编辑区内。支持拖放形式查词。
  3. 桌面贴模式可在“遇鼠标自动回缩”与“遇鼠标自动弹出”两种风格中进行选择。
  4. 重新整合“选项”窗口，增加“自动空行风格”、“记忆导出文件”等多项新设置。
  5. 允许自定义“最小化／还原”与“桌面贴模式”的全局热键。
  6. 增加计算器功能的有效小数位数设定。
  7. 允许选择启用哪些扩展功能。
  8. 关闭时自动记忆窗体位置。
  9. 加入进程互斥。对于同一路径下的minipad.exe只允许运行一个实例。
  10. 使用自动检测外挂语言文件的方式实现对多语言版本及其切换的扩展性支持。
  11. 其他小的改进与bug修正。

2.1.0 ~ 2.1.1 （2007.9.3. ~ 9.5.）

  1. 增加“新建计算页”功能。
  2. 增加"新建备忘录"功能。
  3. 增加常规模式与“伸缩桌面贴”模式的切换功能。
  4. 为最小化／还原切换与常规／桌面贴模式切换操作注册全局热键。
  5. 重新设计“查找／替换”模块，并增加“整词匹配”选项。
  6. 将“选项”菜单下所有不常用的选项整合在“其他设置”对话框中，并增加“自动换行”、“自动缩进”、“启动时自动备份”、“关闭时最小化”、“固定标签宽度”等众多新选项。
  7. 个别bug修正。

2.0.1 ~ 2.0.4 （2007.8.12. ~ 8.16.）

  1. 增加撤销、全选、剪切、复制、粘贴等标准的记事本功能。
  2. 增加标签页次序的左右调整功能。
  3. 增加便笺的“加锁-只读-解锁”状态切换功能。
  4. 增加查找与替换功能。
  5. 增加文本格式文件的导入（打开）与导出（另存为）功能。导入功能支持同时导入多个文件。
  6. 便笺内容修改后最小化时自动保存。
  7. 增加标签栏多行显示的设置。
  8. 增加窗体透明度设置。
  9. 增加本帮助文件。
  10. 个别 bug 修正。

2.0.0 （2007.8.11.）

  1. minipad2 真正意义上的第一个版本，重新设计了界面与功能架构，现定位为小巧随意纯绿色的记便条程序。

1.0 （2007.4.）

  1. minipad2 的前身（minipad 1.0）。简单的笔记软件。主界面为笔记列表 + 编辑区的左右结构。


基本操作

minipad2 的主要定位是纯文本的笔记／便笺软件，笔记与记事功能为其基本功能。

便笺风格操作

软件第一次启动时，为多页面的便笺风格，并已默认建立了一个名为“note1”的页面。在该页面中可自由编辑与记事。编辑完毕无需手动保存或关闭软件，只需将其最小化到托盘区，软件在最小化时会自动保存所有内容。

点击“文件”菜单下的“新建笔记页”（或在标签栏的空白处双击），可新建新的页面进行编辑，并可在各页面间自由切换。

点击“文件”菜单下的“重命名”，可对当前页面进行重命名。另一重命名的方式是在页面中选中待作为标题的文字，然后按 F10，所选文字将作为页面标题。

点击“文件”菜单下的“属性”，可查看或修改当前页面的属性设置。

如需改变标签的位置，直接将其拖曳到目标位置即可。

如需删除某一页面，点击“文件”菜单下的“删除”，或（默认设置下）直接双击该页面的标签即可。

如需对某一页面加锁防止误删除，可点击“文件”菜单下的“加锁切换”，或（默认设置下）在该页面的标签上用中键单击。

软件支持标签页的分组创建与管理。点击“文件”菜单下的“新建组”，可新建标签组。

可使用“导航”菜单下的“后退”、“前进”、“上一层”等导航功能项，在标签页／标签组之间进行导航切换。

在“选项”-->“界面设置”-->“标签栏”中，提供了较多的标签风格设置、如选择标签栏显示在上部／下部、单行／多行风格、标签页宽度固定／可变、是否显示图标、是否高亮当前标签等。

笔记风格操作

点击“工具”菜单下的“显示目录树”，可切换为带树视图的笔记软件风格。在树窗口中可任意新建组（类似于文件夹）与标签页。使用快捷键 Ctrl+Tab，可在编辑区与树／标签区之间切换焦点。

在笔记风格下，软件同样支持通过拖曳的方式改变节点（组、页）的位置与所属。

如需将笔记内容保存为 txt 文件，可点击“文件”菜单下的“导出”。软件支持将整组笔记（包括所有下属节点与子组）批量导出到指定文件夹中，同时保持树结构。

如需导入 txt 文件的内容，可点击“文件”菜单下的“导入”，或从资源管理器中直接将 txt 文件拖入 minipad2 窗口。软件同样支持将指定文件夹中的所有文本文件一次性导入到 minipad2 中，同时保持树结构。

如需将当前页面内容发送到邮件，可点击“文件”菜单下的“发送邮件”，将调用“选项”-->“程序设置”中设定的邮件客户端程序（如未设定，则调用系统默认的邮件客户端）创建新的邮件，并将该页面标题作为邮件标题、内容作为邮件正文。

点击树窗口与编辑区之间的分隔条中间的小按钮，可隐藏／显示树窗口。左键与右键单击各有不同的效果，具体试一下即知。

标签／节点的拖曳操作

不管在多标签风格还是在笔记风格下，软件均支持通过拖曳的方式改变标签／节点（组、页）的位置与所属。
在笔记风格下，拖曳可在左侧的树窗口中进行，也可在右侧的列表窗口中进行，操作类同于资源管理器。

如将某一页拖曳到另一页之上，则被拖页将作为目标页的同级节点。
如将某一页拖曳到某一组之上，默认为将该页作为该组的下属节点。但如拖曳的同时按住 shift 键，则将该节点作为该组的同级节点。
如在拖曳的同时按住 Ctrl 键，则为节点复制操作。
如在拖曳的过程中需要取消拖曳，按 Esc 键即可。

文字编辑操作

编辑器支持拖曳编辑特性，可选中文字以拖曳方式改变位置或进行复制，既可在编辑器内部进行拖曳，也可在编辑器与外部编辑器（如 WPS，EmEditor...）之间进行拖曳操作。
在编辑器按住 Ctrl 键同时滚动鼠标滚轮，可以对编辑区字体进行缩放。按 Ctrl 的同时中键（滚轮）点击，则恢复到缩放前的字体大小。

“编辑”菜单下包含了各类编辑器通用的基本功能，如清空、撤销／重做、全选、剪切／复制／粘贴、查找／替换等。

“编辑”菜单中另有一系列文字工具，如针对选中的局部文字进行高亮或添加下划线、针对所选的多行文字添加序号等。

点击“编辑”-->“插入链接”，可在文字中插入链接（包括网址、文件、节点链接等）。链接在编辑器中高亮显示，双击（或 Ctrl+单击）可执行。

在“选项”-->“程序设置”-->“编辑设置”中，可设定编辑器的编辑特性，如自动缩进、回车时自动插入空行、平滑滚动、单击打开链接、Tab 宽度等。
在“选项”-->“界面设置”-->“编辑器”中，可设定编辑器的界面特性，如字体、字号、文字颜色与背景色，以及页面边距、是否显示行号、是否高亮当前行、文字高亮方案等。

列表类页面的操作

软件除普通的便笺／笔记页外，还支持几种特殊的“功能页”，其中备忘页、链接页、通讯页以及文字模板与剪贴板的编辑页面均为列表（而非文本编辑器）风格。

对于列表页面，点击“编辑”菜单下的“新建项目”（或双击页面空白处），可创建新的项目。
双击现有项目，将弹出编辑窗口，可对该项目进行编辑修改。
右键点击项目，将弹出相应的功能菜单，上有“新建”、“插入”、“编辑”、“删除”等常规功能项。
如需删除某项目，右键点击，选择“删除项目”（支持多选删除）。
如项目标题为空，或为连续三个 '-' 以上，则视为用于分隔的空行，不显示图标与内容。

如需改变项目的位置，选中项目后直接拖曳至目标位置即可（支持 Shift 和 Ctrl 多选）。
如需复制项目，使用 Ctrl+拖曳。
如需将所选项目移动／复制到其它同类页面，同样使用拖曳／Ctrl+拖曳的方式将其拖动到目标页面。

单击列头，可对各项目进行升／降排序。
按住列头并拖放，可调整各列的顺序。

如需改变当前列表页面的属性设置，点击“文件”菜单下的“属性”。在弹出对话框中可设定当前页的列项目、显示风格、是否显示勾选框等，并可将当前设定存为默认风格。
点击“文件”菜单下的“视图”，可直接在不同显示风格（大图标、小图标、列表、详细信息、摘要）之间进行切换。

列表类页面的导出（另存为文件）操作与普通页面相同，但支持以下两种格式的文件：

  1. 存为普通 txt 文件。以 txt 格式保存当前页面上显示的内容。
  2. 存为 *.mep 文件。保存所有内容（包括未选择的列），以及当前页面的格式信息（显示风格，各列宽度...），可用于再次导入（如导入到另一电脑上的 minipad2 中）。

右键菜单操作

软件的各部分（树窗口、列表窗口、标签、编辑区、摘要视图、工具栏空白处）均支持上下文敏感的右键菜单操作。


特色功能

1. 窗体总在最前

minipad2 的主窗体可设为总在最前端，方便记事与笔记摘录。
点击“工具”-->“总在最前”，可切换此项特性。

2. 窗体透明

minipad2 的主窗体可设为半透明效果。透明度在“选项”-->“界面设置”中进行设置。点击“工具”-->“透明效果”，可进行透明／不透明的切换。

3. 桌面边缘隐藏

边缘隐藏是一种类似于最小化的功能，所不同的是在边缘隐藏模式下，当鼠标离开主窗口时窗口将自动移动至桌面边缘之外，在鼠标来到桌面边缘时窗口又自动“移回”。
点击“工具”菜单下的“自动隐藏”，可切换是否启用边缘隐藏模式。
在边缘隐藏模式下，主窗口将自动变为工具窗口风格（标题栏仅显示关闭按钮，不在任务栏显示），且自动“总在最前”。

相关的一些设置（“自动隐藏”的方位、回缩检测延迟、弹出检测延迟、动画效果的时间）在“工具”-->“选项”-->“程序设置”-->“自动隐藏”中进行设定。

关于自动隐藏方位，有左、上、右、下四种固定方位、以及一种特殊的“自由”方式可选。在“自由”方式下，软件自动检测离窗口最近的桌面边缘进行隐藏。即假若原先是在右侧隐藏，现在希望在上侧隐藏，则无需在选项中进行重新设定，只需将窗口拖至较靠近桌面上侧的位置即可。

4. 自动调整界面元素

所谓“自动调整界面元素”，指的是当用鼠标缩小主窗体大小时，随着窗口的缩小一些界面元素（树窗口、标签栏、工具栏、菜单栏等）将逐渐依次隐藏。在窗口缩到很小的情况下，所有其它界面元素均隐藏以后，最终将只剩一个编辑区。
这一特性在将 minipad2 作为一个小编辑窗口置于前端进行笔记摘录时十分有用。可以在窗口调小时腾出最大的空间给编辑区。
“自动调整”特性的启用与否在“选项”窗口中的“界面设置”中进行设定。同时可设定其“敏感度”。敏感度越高，在将窗口缩小时“多余的元素”越“易于消失”。
当菜单栏自动隐藏之后，如需使用菜单功能，可在标题栏点击右键。

5. 外部滚动

在“选项”-->“程序设置”中，可选择是否开启“外部滚动”特性。
在开启“外部滚动”特性的情况下，如果当前输入焦点在 minipad2 编辑区内，同时在 minipad2 主窗口之外（比如对着doc、pdf文档，或对着浏览器页面）滚动滚轮，此时滚动的将是鼠标之下的页面，而非 minipad2 的编辑区。
这一特性对于将 minipad2 作为前置窗口进行笔记摘录的使用者将会比较方便，而无须将焦点在 minipad2 与另一程序之间反复切换。

6. 笔记摘录

minipad2 可作为资料收集面板。使用“选项”-->“程序设置”-->“笔记摘录”中设定的一系列快捷键，可方便地将所浏览的网页或文件中的内容抓取到 minipad2 的笔记页中，或直接抓取并保存到 txt 文件中。

自动笔记摘录的另一方法是勾选托盘区菜单中的“自动记录”项。此时在其它软件或浏览器中的一切复制操作，其复制内容均将自动追加到 minipad2 的当前页面中。当需要停止资料收集时，只需将“自动记录”勾除即可。

7. 笔记导航

“导航”菜单下提供一系列方便快速定位笔记的功能，如“后退”、“前进”、“最近创建”、“最近修改”、“最近访问”等。您也可将最常用的笔记页添加到“收藏夹”中，方便快速定位。

8. 文字的局部高亮

minipad2 在保持纯文本特色的基础上，支持对局部所选的重点文字进行下划线或背景高亮设定，相关菜单项为“编辑”-->“文字工具”。软件共支持四种配色方案，详见“选项”-->“界面设置”-->“编辑器”中的相关设定。

9. 全局搜索

软件自带强大的 全局搜索 功能，可按设定条件对各种类型的页面进行标题、全文以及其他相关属性的搜索。搜索结果以列表形式显示，双击任一条目可切换到该页面，同时对所有的匹配文字进行高亮显示。

10. 摘要视图

对于列表型的页面，除了常规的图标、列表、详细信息等视图外，还支持独特的“摘要”视图。在该视图模式下，各项目的摘要内容将一览无遗。

11. 数据保存与备份

软件在最小化时、桌面边缘隐藏时、以及关闭时均会对各项设置以及已修改的页面内容进行自动保存。一般情况下无需使用手动保存功能。
默认设置下，软件在编辑过程中每隔 10min 会自动保存一次。每保存 10 次会额外做一次备份（即将数据文件复制一份到设定的备份路径下）。软件自动保存最近的 5 份备份文件。
在“选项”-->“程序设置”-->“保存与备份”中，可设置定时保存与定时备份功能，并可设定备份数与备份路径。

12. 外部存储

minipad2 的任意一个笔记页均可选择是将数据存储于数据库文件中、还是存于独立的外部文本文件中。导入与文件拖入均支持外部存储方式。这使得 minipad2 可作为大量文本文件或电子书的树状结构的虚拟管理器使用，而无需将所有文本存储于单一的数据库中，大大分散了数据存取风险，提高了数据载入效率。
要切换一个页面的外部存储属性，请点击“文件”-->“属性”中的“保存”选项卡。

13. 回收站

软件中删除的页面将自动进入回收站。回收站支持容量设定（“选项”-->“程序设置”），超过此容量时，将自动清除最“旧”的删除页面。因此一般情况下无需手动清空回收站，也无须担心时间长了以后废旧页面太多影响软件性能的问题。
如要恢复误删除的页面，直接从回收站中将该页面拖出即可。


扩展功能

  1. 计算页
  2. 备忘页
  3. 词典页
  4. 链接页
  5. 通讯页
  6. 文字模板
  7. 多重剪贴板


计算页

点击“文件”-->“新建功能页”-->“新建计算页”，可以创建计算页。在计算页中可自由输入表达式进行求值计算。

基本功能

内置支持：

+、-、*、/：四则混合运算（*、/ 亦可写为 ×、÷）
^：乘方
%：百分号
单变量函数：lg, ln, exp, sqrt, sqr, rad, deg, sin, asin/arcsin, cos, acos/arccos, tg/tan, atan/arctan, cot, acot/arccot
双变量函数 log(x,y)：以 y 为底的 x 的对数。相当于 lgx/lgy。
round(x,y)（x 精确到 y 位小数）
整数计算：int(x)（对 x 取整）, \(整除), !（取余）
常数：pi，e
任意层括号嵌套。

注意，以上数学符号均为半角符号，请勿输入全角。输入不区分大小写。表达式内／外的多余空格将会自动删除。

表达式示例：

(5+2)*(7-3)
3^2 - sin5
((15*9)^3 - ln20) + 12

输入表达式后，按回车或"="号自动求值。
如对原表达式进行修改，修改完后按回车或"="号（在任何位置，不需到行末，也无需删除原结果）将重新求值。
如表达式存在语法错误或数值溢出，将在行尾显示出错信息。此时可回到前一行对原表达式进行修改，并按回车重新求值。

自定义函数／变量

计算页除内置函数外，还支持自定义函数／变量。
自定义函数／变量分为两类，一类为全局函数／变量，在“选项”-->“扩展功能”-->“计算页”中进行设定，其有效范围为所有的计算页（包括普通笔记页中的嵌入式计算）。

示例：

a=3
error(x,y)=(y-x)/y
DensityRound(d,h,m)=m*4/(pi*d^2*h)

另一类为直接写在当前计算页中的自定义函数／变量，其作用域为当前计算页、定义之后。这类自定义函数／变量须以#开头。

示例：

#va=5
#myfunc(x,y)=x*y+va

局部变量/函数可被任意重定义。例如原先在第三行设定 #va=5，随后做了些计算。随后在第12行设定 #va=8。则在第12行之后的计算将取 va=8 而非 va=5。（但若此时修改了第3至12行之间的计算式并作重计算，则在这些计算式中仍取 va=5。因局部变量仅对定义行之后的行有效）

定义自定义函数／变量后，即可在表达式中随意使用。如输入：
myfunc(7.2,9)+DensityRound(12.7,2,128.6)

回车后得到：
myfunc(7.2,9)+DensityRound(12.7,2,128.6) = 70.307591

其它特性

在计算页中输入 ? 并回车，可得到关于计算页所支持的运算符与内置函数／变量的简单帮助。

输入 ?list 并回车，可列出全局自定义函数／变量及当前计算页的局部自定义函数／变量的清单。

以 // 开头的行视为注释，不予求值计算。

在输入表达式后，若使用 Shift_Enter 求值，则所得的计算结果将自动复制到下一新行，以便基于该计算结果进行新的计算。若使用 Ctrl_Enter 求值，则求值完成后不换行（这一特性是为了方便在求值后按 Tab 并以 // 起头在同一行中写入注释，或同一行中以 Tab 分隔进行多个求值计算）

按 F9，将对整页内容从头至尾逐行进行重计算。适用于设定变量、使用该变量进行一系列计算后，再回到开头修改变量赋值并进行重计算的场合。

软件支持在普通便笺页中的嵌入式计算。在普通便笺页中输入表达式后按 shift+回车，即可进行求值。若使用 Ctrl_Enter 求值，则求值完成后不换行。

相关选项

在“选项”-->“计算页”中，可设定计算结果的有效小数位数、三角运算的方式（弧度制／角度制）、自定义函数列表等。详见本帮助文档的“选项”-->“扩展功能”-->“计算页”章节。


备忘页

minipad2 的备忘页兼具备忘提醒、计划任务与简单日程记录的功能。
点击“文件”-->“新建功能页”-->“新建备忘页”，可以创建备忘页。

基本操作

点击“编辑”-->“新建项目”（或在备忘页空白处直接双击），将弹出“新建备忘条目”窗口，可以创建新的备忘条目。
双击已创建的备忘条目，将弹出“编辑备忘条目”窗口，可对该条目进行编辑修改。
在备忘提醒的时间到达时，将在桌面右下角弹出提醒窗口，同时伴随提示音。此时如需要在一定时间后再次提醒，可在提醒窗口中设定再次提醒的时间。
如需删除某项条目，右键点击该条目，选择“删除项目”。
如需调整备忘条目的排序，选择相应条目直接拖动到目标位置即可。
在建有多个“备忘页”的情况下，可将备忘项目在各个页面间自由拖动，以调整分组或进行复制。

备忘条目编辑对话框

标题：备忘条目标题

操作：分为定时提醒、执行任务、无操作三类。

  • 定时提醒：功能类似于闹钟。将在“时间”项所规定的时间（精确到分钟）在桌面右下角弹出小的提醒窗口，窗口中的文字为“描述”中的文字。
  • 执行任务：计划任务功能。将在“时间”项所规定的执行“描述”中的操作（如打开程序、打开网页等）。
  • 无操作：仅作为日程记事，不作提醒。

时间：输入条目所对应的时间（格式：年-月-日 时:分）。分为以下六类：

  • 当天：仅为当天一次性提醒（或一次性执行任务）。
  • 每天：每天某一时间进行提醒或执行任务。
  • 每周：每周的某几天（写法类如：1,3,6-7）在设定时间进行提醒或执行任务。其中星期天可写成0，也可写成7。
  • 每月：每月的某几天（写法类如：3,15,22-28）在设定时间进行提醒或执行任务。
  • 每年：每年的某几天（写法类如：3-20,9-3,12-24。即"月-日"，多个日期之间以逗号间隔）在设定时间进行提醒或执行任务。
  • 日程：设定某一日期范围。该选项仅针对“无操作”，用于日程记事。
  • 无时间：类似于“日程”，但无日期范围。仅针对“无操作”，用于记事。

描述：备忘条目的文字描述。

  • 对于定时提醒：该描述将出现在弹出的提醒窗口中。
  • 对于计划任务：所需执行的任务（打开程序、打开网页等）。一般使用“添加”按钮进行添加。可添加多项任务（如同时打开多个程序）。参见“链接页”中的“批处理链接”。

提示音：在定时提醒或执行任务时伴随的提示音。可选 PC 发声或 *.wav 格式的声音文件。声音文件可点击“...”按钮进行设定。
如选择了“声音文件”选项而声音文件输入框留空，则仍然使用默认的 PC 发声进行提示。

示例：

1. 设定一闹钟，在每晚 19:00 提示“别打游戏啦，该做作业啦！”
在备忘页中空白处双击，在弹出的“新建备忘条目”对话框中输入标题“做作业提示”，描述项输入“别打游戏啦，该做作业啦！”，时间项选择“每天”，时间设为 19:00，操作为“定时提醒”，设定提示音，随后点击“确定”。
在每晚的 19:00，将会按照上述设定弹出提示小窗口。

2. 设定一任务，每周逢1、3、5中午执行磁盘扫描。
在备忘页中空白处双击，在弹出的“新建备忘条目”对话框中输入标题“磁盘扫描”，在“描述”右侧点击“添加”按钮，选择磁盘扫描软件的 exe 主执行文件，时间项选择“每周”，右侧输入框输入“1,3,5”，时间设为 12:00，操作为“执行任务”，随后点击“确定”。
在每周一、三、五的中午 12:00，将自动启动磁盘扫描程序，进行磁盘扫描。


词典页

点击“文件”-->“新建功能页”-->“新建词典页”，可以创建词典页。

基本操作

在软件配置了相关词典的情况下，在词典页中输入单词并回车，可查询单词释义。
如输入有误或词库中查不到该单词，将显示“not found!”。如需修改该单词，直接在单词上修改后重新按回车即可。

词典配置

软件的 中文论坛 有较多词典下载。将下载的词典文件解压后放置在 minipad2\dict 子路径下，随后在“选项”-->“扩展功能”-->“词典页”中进行配置。
词典支持配置任意数量的词典。在配置有多本词典的情况下，如选择“显示多词典检索结果”，则将在所有词典中进行依次检索，并同时显示所有检索结果。否则在依次检索的过程中一旦在某一词典中得到了检索结果，将立即显示该检索结果，不再在后面的词典中继续进行检索。（但按 Ctrl+Enter 仍可显示多词典查询结果）

自制词典

minipad2 支持的词典内容不限，可为中英互译、其他语言、技术条目索引或百科全书等等。

词典为纯文本文件，用户可以使用记事本软件自行编辑，只需遵循如下的格式：

  • 第一行：@词典名称//备注
  • 以后各行：单词\t释义
  • 末行：空行

即第一行为词典名称（备注项为可选项），其后每一词条占一行（如词条在显示时需为多行，用 \n 代替回车符），单词与释义之间以制表符tab相隔，最后一行需为空行。
所有词条需以字母或拼音顺序排序（建议从软件的 中文论坛 的词典交流区下载排序软件 DictSorter 进行排序）。
编辑完成后保存在 minipad2\dict 之下，后缀名 *.dic，文本编码 UTF16LE（在 windows 记事本中称为 Unicode），随后即可在 minipad2 的选项中配置使用。

嵌入式查词

软件支持在普通笔记页中的嵌入式查词。在普通笔记页中输入词条后按 shift + enter，即可进行查询。ctrl + enter 的含义与词典页同。

注：在同时开启计算器与词典功能的情况下，在普通页中按下 shift + enter 后，软件会自行判断。如表达式中包含数字，则作为嵌入式计算处理，否则作为嵌入式查词处理。如果要强制作为嵌入式查词处理（比如针对一些包含数字的词条），请在词条前加上 @（常规词库）或 $（范围型查询）。

范围型查询

minipad2 除支持常规的匹配型词库外，还支持范围查询型的词库。范围查询型词库的格式如下：

  • 第一行：$词典名称//备注
  • 以后各行：下范围\t上范围\t释义
  • 末行：空行

各条目同样需按字母顺序排序。

例如如下的 IPBase 中的条目：

061.191.103.248 061.191.103.255 安徽省六安市 电信
061.191.104.000 061.191.109.049 安徽省巢湖市 电信

查询时输入：$061.191.103.252 并按回车，即得到：

$061.191.103.252: [IPBase] 安徽省六安市 电信

屏幕取词

minipad2 支持屏幕取词功能。在任意软件（编辑器，浏览器...）中选中待查询的单词，按下在“选项”-->“扩展功能”-->“词典页”中设定的取词热键，将实时显示查询结果。查询结果同时自动复制到系统剪贴板，方便粘贴到其它场合。


链接页

链接页类似于快启面板或虚拟桌面，可用于存放与管理软件、文件与网址的快捷方式（以下称为“链接”）。
点击“文件”-->“新建功能页”-->“新建链接页”，可以创建链接页。

基本操作

点击“编辑”-->“新建项目”（或在链接页空白处直接双击），将弹出“新建链接”窗口，可以创建新的链接。
（添加链接的另一方式是直接从桌面或资源管理器中将文件／文件夹／图标拖入到 minipad2 的链接页中）
右键单击链接项目，在弹出菜单中点击“编辑项目”，则可对所选项目进行编辑修改。
双击现有的链接图标，则将运行该链接所关联的项目（启动程序、打开文件、打开网页...）
如需删除某一链接，右键点击该条目，选择“删除项目”。
如需调整链接项目的排序，选择相应条目直接拖动到目标位置即可。
在建有多个“链接页”的情况下，可将链接项目在各个页面间自由拖动，以调整分组或进行复制。

链接编辑对话框

标题：链接的标题

类别：包含程序／文件、文件夹、网址、收件地址、批处理五类。

  • 程序／文件：点击“...”按钮，可选择所要关联的文件。执行这类链接将打开关联的程序或文件。如该可执行程序带参数，则请将程序本身用双引号括起。例如："c:\notepad.exe" d:\123.txt
  • 文件夹：点击“...”按钮，可选择所要关联的文件夹。执行这类链接将打开关联的文件夹。
  • 网址：直接在“链接”中输入网址。执行这类链接将启动默认浏览器并进入相应网址。
  • 收件地址：直接在“链接”中输入邮件地址。执行这类链接将调用默认邮件客户端创建新的邮件，收件人为“链接”中的邮件地址。
  • 批处理：在“链接”（多行编辑器）中逐行输入多个关联项目（可为程序，文件，文件夹，网址...），或使用“添加”按钮添加多个程序／文件。执行这类链接将同时打开所有的关联项目。

热键：该链接对应的全局热键。

缩写：输入用于在弹出菜单中快速存取该项目的缩写字母（仅针对快速链接。获取类似于 win+r 快速启动的效果）。

快速链接

快速链接是一个较为特殊的链接页。其中的链接项目可通过托盘区右键菜单、或热键呼出菜单存取。

点击“工具”-->“快速链接管理”，可呼出快速链接页，对其中的项目执行增删、编辑、运行等操作。其操作与普通链接页相同，同样支持从外部拖入链接。

右键点击托盘图标，在托盘菜单中包含“快速链接”的下拉菜单。

使用“选项”-->“链接页”中设定的“快速链接热键”，可呼出快速链接的弹出菜单。在弹出菜单中既可使用鼠标点击所需项目，也可按 1..9 数字键直接调用前九项。如按住 Shift 再点击某一项，则将同时启动该项与该项之上的所有项目。

若在“选项”-->“扩展功能”-->“链接页”中勾选了“启用子条目热键”，则可使用子条目热键直接启动前九个项目。（若快速链接菜单的热键为 Ctrl+Alt+D，则前九个项目的热键自动相应为 Ctrl+Alt+1..9）

相关选项

在“选项”-->“扩展功能”-->“链接页”中，包含关于链接页的一些设定（不读取链接图标、打开链接后自动最小化 minipad2、快速链接热键...）。详见苯帮助文档的“选项”-->“扩展功能”-->“链接页”章节。


通讯页

minipad2 提供简单的通讯录功能。点击“文件”-->“新建功能页”-->“新建通讯页”，即可创建通讯页。

基本操作

点击“编辑”-->“新建项目”（或在通讯页空白处直接双击），将弹出“新建联系人”窗口，可以添加新的联系人。
双击现有的联系人，将弹出“编辑联系人”窗口，可对该条目进行编辑修改。
如需删除某一联系人，右键点击该条目，选择“删除项目”。
如需调整联系人的排序，选择相应条目直接拖动到目标位置即可。
在建有多个“通讯页”的情况下，可将联系人条目在各个页面间自由拖动，以调整分组或进行复制。

联系人编辑对话框

联系人编辑对话框包含姓名、单位、地址、电话、Email等相关项目，由于其含义一看即知，此处不再赘述。


文字模板

minipad2 集成了文字模板功能。用户可将平日常用的文字片段或符号添加到 minipad2 的文字模板列表中，方便在各类编辑场合粘贴与复用。

基本操作

点击“工具”-->“文字模板管理”，可打开文字模板列表，对文字模板进行编辑与管理。
点击“编辑”-->“新建项目”（或在页面空白处直接双击），将弹出“新建文字模板”窗口，可以添加新的文字模板。
（添加文字模板的另一种方式是在任意编辑器中选中目标文字，随后按下在“选项”-->“文字模板”中设定的“捕捉热键”，所选文字将自动添加到文字模板列表中。）
双击现有的文字模板，将弹出“编辑文字模板”窗口，可对该条目进行编辑修改。
如需删除某一文字模板，右键点击该条目，选择“删除项目”。
如需调整文字模板的排序，选择相应条目直接拖动到目标位置即可。

在 minipad2 的编辑区中，点击“编辑”-->“插入模板文字”的下拉菜单条目，可在当前页面中插入模板文字。
在其他 windows 编辑器中，使用 minipad2 的托盘区右键菜单可进行相同操作，也可使用“选项”-->“文字模板”中设定的全局热键呼出文字模板的弹出菜单进行插入操作。在弹出菜单中既可使用鼠标点击所需项目，也可按 1..9 数字键直接调用前九项。
在弹出菜单中如按住 Shift 再点击某一项，则将一次性将该项与其上的所有项目同时贴入。
对于单条文字的直接插入，既可使用为该条目设立的独立热键，也可在勾选“子条目热键”的情况下使用相应的热键插入前 9 条文字。（若呼出文字模板快捷菜单的全局热键为“Ctrl-D”，则直接插入第一至第九个条目的全局热键为 Ctrl-1 至 Ctrl-9。）

文字模板编辑对话框

标题：文字模板的标题。该标题仅用于列表中的条目显示，不作为实际使用时的插入文字。

文字：模板正文，即实际使用时的插入文字。

热键：用于直接插入该项文字模板的全局热键。

缩写：输入用于在弹出菜单中快速存取该项目的缩写字母。

指代符

文字模板的正文部分支持如下指代符号：

转义符：

  • %d: 当前日期（格式遵循系统区域选项中的短日期格式）
  • %i: 当前时间（格式遵循系统区域选项中的时间格式）
  • %u(###)：当前日期时间，### 代表自定义格式（如：yyyy-MM-dd HH:mm:ss）。详细格式可参考区域选项中的设置与说明。
  • %t：制表符
  • %n：回车符
  • %s(n)：n个连续的"-"号
  • %s(###,n): n个连续的###。
  • %c(##)：任意ASCII字符（包括不可见字符）。##为ASCII码。如Tab为：%c(9)，回车为：%c(13)%c(10)

模拟按键：

  • ~t：Tab
  • ~n：Enter
  • ~l：Left
  • ~r：Right
  • ~u：Up
  • ~d：Down
  • ~h：Home
  • ~e：End

模拟按键后可加(n)，如~l(5), 表示连按五次向左键。

软件支持常规文字与转义符、模拟按键等的混合书写。在文字插入时，转义符将被自动展开与替换为相应文字，模拟按键则将转化为按键操作（如用于自动填表）。

其它特殊指代符：
  • ~c：插入文字模板后的光标所在位置。
  • ~s：指代所选区域的文字。

这两个特殊指代符比较适合于制作 Html 的 tag 模板。

示例：

%d %i：将被展开为类似“2009-06-09 22:10”的文字。

%t第一项%n%s(*-,12)%n%t第二项：将被展开为：
第一项
*-*-*-*-*-*-*-*-*-*-*-*-
第二项

username~tpassword~n：将被展开为：
username (Press Tab) password (Press Enter)

<p>~c</p>：当粘贴时将为：
<p></p> 同时光标处于<p>与</p>之间。

<p>~s</p>：当粘贴时将自动在选区文字左右分别加上<p>与</p>（不替换选区文字）

<a ref="~s">~c</a>：假设在某编辑器中选中 http://www.nebulasoft.cn 并粘贴此模板，则粘贴后的文字将成为：
<a ref="http://www.nebulasoft.cn"></a>，同时光标插入点位于 </a> 左侧。

相关选项

在“选项”-->“文字模板”中，可设定弹出菜单的全局热键、是否使用子条目热键等。详见本帮助文档的“选项”-->“扩展功能”-->“文字模板”章节。


多重剪贴板

minipad2 集成了剪贴板增强功能。用户在任何 windows 程序中复制或剪切到剪贴板的文字均将在 minipad2 的剪贴历史队列中保存，方便在各类编辑场合粘贴与复用。

基本操作

在“工具”主菜单或托盘区菜单中点击“剪贴板监视”，即可启用剪贴板监视。
在剪贴板监视状态下，程序将跟踪与捕捉系统中发生的文字复制过程，将复制到系统剪贴板中的文字同步添加到 minipad2 的剪贴文字列表中。新加入的项目将出现在第一项，原先的项目依次下移。

在 minipad2 的编辑区中，点击“编辑”-->“插入剪贴文字”的下拉菜单条目可插入剪贴文字。
在其他 windows 编辑器中，使用 minipad2 的托盘区右键菜单可进行相同操作，也可使用“选项”-->“多重剪贴板”中设定的全局热键呼出剪贴条目的弹出菜单进行插入操作。在弹出菜单中既可使用鼠标点击所需项目，也可按 1..9 数字键直接调用前九项。
在弹出菜单中如按住 Shift 再点击某一项，则将一次性将该项与其上的所有项目同时贴入。
如在“选项”-->“多重剪贴板”中勾选了“子条目热键”，则可使用相应的热键直接插入前 9 条文字。（若呼出剪贴板快捷菜单的全局热键为“Alt-D”，则直接插入第一至第九个条目的全局热键为 Alt-1 至 Alt-9。）

点击“工具”-->“清空剪贴条目”，可清空当前的剪贴文字列表。
点击“工具”-->“剪贴板管理”，可打开剪贴项目列表，对剪贴项目进行查看、编辑与管理。

相关选项

在“选项”-->“多重剪贴板”中，提供了较丰富的相关设定，如条目数、最大字节数、弹出菜单的全局热键、子条目热键等。详见本帮助文档的“选项”-->“多重剪贴板”章节。


菜单条目解析

  1. 文件
  2. 编辑
  3. 导航
  4. 工具
  5. 帮助
  6. 托盘菜单
  7. 快捷键设定


文件

本菜单针对所有类型的页面，涉及页面的各种常规操作。

新建笔记页：新建常规的笔记／便笺页。（一般作为当前节点的最后一个平行节点。Ctrl_点击则将插入新节点到当前节点之前。如果当前节点为组，则直接点击“新建”将创建为该组的子节点，Shift_点击则创建为该组的平行节点。下同。）

新建功能页：新建计算页、备忘页等不同于普通笔记页的特殊功能页。
新建计算页：新建一专用于表达式求值的功能页，可作为计算器使用。（详见“扩展功能”-->“计算页”章节）
新建备忘页：新建一专用于定时提醒的功能页，可任意插入备忘条目并设定提醒时间。（详见“扩展功能”-->“备忘页”）
 新建词典页：新建一用于查词的功能页。（详见“扩展功能”-->“词典页”）
新建链接页：新建一可作为快启面板的功能页。（详见“扩展功能”-->“链接页”）
新建通讯页：新建一可作为通讯录使用的功能页。（详见“扩展功能”-->“通讯页”）

新建组：新建组（文件夹）。每一组下可任意新建笔记页／功能页。

重命名：修改当前标签页的名称。

加锁切换：对当前页面实行加锁、只读或解锁操作。
事实上，页面共可在常规、加锁、追加与只读四种状态间切换：

  • 常规：页面可任意进行编辑。可删除页面。
  • 加锁（+）：只允许编辑，不允许删除页面。
  • 追加（*）：进入页面时所有原有内容均处于保护状态不允许编辑，只允许在原有文字基础上添加新的文字。不允许删除页面。
  • 只读（#）：页面内容为只读，不允许编辑或添加。不允许删除页面。
其中常规、加锁与只读三种状态可直接使用“加锁切换”菜单项切换，而“追加”则需在“属性”对话框中进行设置。

保存：手动保存编辑内容。（软件本身有完善的自动保存与定时保存机制，一般情况下很少需要使用手动保存功能）

删除：删除当前标签页。

属性：点击打开“属性”对话框。在对话框中可修改页面的标题，更换页面图标（点击图标按钮），设置追加、只读等属性，查看节点路径、时间戳等信息，或写入备注信息。对于文本页面，可设置是否为外部保存（保存于单独的 txt 文件中），以及选择保存文件；对于列表型页面，可设定当前页面所需要显示的列、显示风格（大图标、小图标、列表、详细信息、摘要）、是否为整行选中风格、是否显示勾选框、是否显示网格线等，并可将当前设定存为新建同类型页面时的默认风格。

视图：针对当前的列表页面，在大图标、小图标、列表、详细信息、摘要五种显示风格之间进行切换。

导入：导入外部文件内容。支持从文件导入，与从文件夹进行整组导入。对于文件导入，支持以下两种格式：

  • *.txt：导入文本文件。将文件内容以新笔记页的形式导入到 minipad2 中。
  • *.mep：重新导入先前导出的列表类页面。
导入操作支持多选，即一次选择多个文件同时导入。
导入文件可选择为外部存储方式。即数据仍然存储于原有的 txt 文件中，在 minipad2 中仅新建一个节点实现对该文件的引用。
导入的另一方式是直接从资源管理器中将文件／文件夹拖入 minipad2 窗口中。
在多个文件的导入过程中，按住 ESC 可终止导入。

导出：将当前页面的内容导出到剪贴板、文件或文件夹。其中后两种方式的导出：

  • 对于文本形式的页面（笔记页、计算页、词典页）：另存为 txt 文本文件。
  • 对于列表形式的页面（备忘页、链接页、通讯页、文字模板）：可导出为以下两种格式之一：
    1. 存为 *.txt 文件。以纯文本格式保存当前页面上显示的内容。
    2. 存为 *.mep 文件。保存所有内容（包括未选择的列），以及当前页面的格式信息（显示风格，各列宽度...），可用于再次导入（如导入到另一电脑上的 minipad2 中）。
  • 对于整组的批量导出，可选择导出到文件夹同时保留树型结构（即子页面导出为单独的文本文件，子组导出为子文件夹），也可设置为将所有节点的内容合并导出到单一的文本文件中。
文本文件的编码可在 Ansi、UTF-8、UTF16LE（Unicode）、UTF16BE（Unicode Big Endian） 四种编码中进行选择。

发送邮件：调用“选项”-->“程序设置”中设定的邮件客户端程序（如未设定，则调用系统默认的邮件客户端），将当前页面的内容以电子邮件形式发送，以页面标题作为邮件标题，页面内容作为邮件正文。

退出：退出程序。


编辑

清空：清空当前页面内容。
撤销：撤销最近一次的编辑操作。
重做：恢复被撤销了的编辑操作。
全选：将当前编辑区的文字或列表页的所有项目全部选中。

剪切：将当前所选文字剪切至剪贴板。
复制：将当前所选文字复制至剪贴板。
粘贴：在光标所在处插入剪贴板中的文字。
删除：删除当前所选文字或列表项目。

新建项目：在当前页面中新建新的项目。
插入项目：插入一新的项目到所选项目之前。
编辑项目：编辑当前所选项目。

自动换行：设定编辑区是否为自动换行（即一行文字到达编辑区右边界时自动换为下一行）风格。
文字工具：下拉菜单，包含如下文字工具：
  高亮 1 .. 高亮 4：对局部所选文字设置下划线或背景高亮。具体设置参见“选项”-->“界面设置”-->“编辑器”。
  移除高亮效果：移除当前所选文字块的高亮效果。
  有序列表：为当前所选多行文字逐行添加序号。
  无序列表 1、2：为当前所选多行文字逐行添加列表前缀（默认为 >、*。具体前缀可在“选项”-->“程序设置”-->“编辑设置”中进行设置。
  移除列表：移除所选多行文字的序号或列表前缀。
  删除空行：删除所选文字块中的空行、或当前页面中的所有空行（在未选中任何文字块的情况下）
  只空一行：针对当前所选文字块、或当前页面的全部内容（在未选中任何文字块的情况下），删除所有多余空行，仅在每个段落之间保留一个空行。

查找／替换：打开“查找／替换”窗口，输入待查找／替换的文字，设定查找方向、是否区分大小写、是否整词匹配、是否仅在选区内进行查找、是否在当前页面循环查找、是否高亮查找结果，以及是否在找到第一匹配项后即退出本对话框，随后点击“确定”进行查找。对话框中另有“查找下一个”（若按住 Shift 则为查找上一个）、“替换并查找下一个”（若按住 Shift 则为替换并查找上一个）、“替换全部”等按钮，方便进行后续查找与替换。
后续查找：下拉菜单，包含如下几项：
  查找下一个：按前面输入的查找内容查找下一处出现的位置（若设定为向下查找并循环查找，则到达页尾后自动回卷至页首继续查找。
  查找上一个：反向查找上一处出现的位置。
  替换并查找下一个：替换当前查找结果并继续查找下一项。
  替换并查找上一个：替换当前查找结果并继续查找上一项。
  替换全部：在整个编辑区范围内用目标字符串替换全部查找结果。
高亮查找结果：对当前页面中的匹配项目进行高亮显示。

插入链接：打开“插入链接”对话框，选择链接类别（程序／文件，文件夹，网址，节点...），输入链接，随后点击“确定”以在当前光标处插入超链接。在默认设置下，双击（或 Ctrl+单击）超链接可打开该链接。
插入模板文字：下拉式菜单，在光标所在处插入文字模板。（详见“扩展功能”-->“文字模板”）
插入剪贴文字：下拉式菜单，在光标所在处插入剪贴文字。（详见“扩展功能”-->“多重剪贴板”）


导航

后退：回到历史记录中的前一页面。
前进：回到历史记录中的下一页面。
上一层：回到上一层目录。

最近的笔记：下拉菜单，包含如下菜单项：
  最近创建：显示最近创建的笔记的列表。
  最近修改：显示最近修改的笔记的列表。
  最近访问：显示最近访问的笔记的列表。
  管理最近的笔记：在树窗口中添加或切换到“最近的笔记”项目。
收藏夹：显示添加到收藏夹中的笔记列表。并包含如下两个子菜单项：
  添加到收藏夹／从收藏夹移除：将当前页面添加到收藏夹，或从收藏夹移除。
  收藏夹管理：在树窗口中添加或切换到“收藏夹”项目。

搜索：打开“搜索”对话框，选择页面类别（笔记页，计算页，备忘页...）与待搜索的字段（标题，内容，创建时间...），输入搜索条件，点击“确定”进行搜索。搜索结果将以列表形式显示在树窗口的“搜索”节点中。
回收站管理：点击此菜单项，将选中树窗口中的“回收站”项目，右侧列表为回收站中的节点。可进行节点移出（使用拖放操作）、回收站清空、或（彻底）删除回收站中的某些项目等操作。


工具

显示目录树：选择是否显示目录树，即在多页面便笺风格／笔记风格之间进行切换。
总在最前：将本程序的窗体保持在所有其他 Windows 程序的最前端（在编辑时需要同时查看其他窗口内容的场合下非常有用）。
透明效果：切换窗体为半透明效果。（具体透明度在“选项”-->“界面设置”中进行设定）
自动隐藏：当鼠标离开时，窗口自动隐藏到桌面边缘。（详见“特色功能”中关于自动隐藏的介绍）

文字模板管理：以列表形式编辑／查看所有模板文字。（详见“扩展功能”-->“文字模板”）
快速链接管理：以列表形式管理所有快速链接。（详见“扩展功能”-->“链接页”）

剪贴板监视：启动／停止监视剪贴板。
清空剪贴条目：清空所有缓存的剪贴条目。
剪贴板管理：以列表形式编辑／查看所有剪贴项目。（详见“扩展功能”-->“多重剪贴板”）

统计信息：打开“统计信息”对话框，在“当前页”选项卡中可看到当前页面的字符数、单词数、行数与段落数，或当前列表的项目数。在“数据库”选项卡中可看到对数据库中各种类型的页面与项目的统计数据。

自定义工具栏：弹出“自定义工具栏”对话框，设置工具栏上显示哪些按钮。对话框中右侧为现有的工具按钮列表，左侧为可添加的按钮。两者之间支持拖曳移动的方式。
选项：弹出“选项”对话框，进行软件的各项选项设置。（详见“选项”章节）


帮助

帮助主题：打开本帮助文件。

主页：链接到软件的 主页。
论坛：链接到软件的 主论坛。

捐助：链接到软件的 捐助页面。
关于：显示软件的版本、官方网站与作者信息。


托盘菜单

以下为托盘区特有的一些菜单条目：

新建笔记：使用小窗口的形式新建笔记页。在该窗口中若第一行以@开头，则该行将作为新笔记的标题。

自动记录：开启／关闭自动记录功能。详见：“特色功能”-->“笔记摘录”。

最小化／还原：最小化／还原主窗口。


快捷键设定

minipad2 支持对菜单项目（以及个别纯使用快捷键、而无对应菜单条目的功能）进行快捷键的自定义。设定方法如下：

在minipad2\路径下创建一个名为 accel.txt 的纯文本文件。在其中用“项目ID=快捷键”的方式写入重定义内容。例如如下重定义：

1010=Alt+W
1130=F7
1160=Shift+Ctrl+P
1720=

将把“新建笔记页”（ID=1010）的快捷键重定义为 Alt+W，“加锁切换”（1130）重定义为 F7，“属性”（1160）设定为 Shift+Ctrl+P，并取消“总在最前”（1720）的快捷键。

各菜单项目的 ID 及其默认快捷键列表如下：

  • 新建笔记页：1010（Ctrl+N）
  • 新建功能页：1020
  • 新建计算页：1030
  • 新建备忘页：1040
  • 新建词典页：1050
  • 新建链接页：1060
  • 新建通讯页：1070
  • 新建组：1110（Ctrl+G）
  • 重命名：1120（F2）
  • 加锁切换：1130（F6）
  • 删除节点：1140（Shift+Del）
  • 保存：1150（Ctrl+S）
  • 属性：1160
  • 视图：1170
  • 导入：1180
  • 导出：1190
  • 发送邮件：1200
  • 退出：1210
  • 清空：1310（Ctrl+L）
  • 撤销：1320（Ctrl+Z）
  • 重做：1330（Ctrl+Y）
  • 全选：1340（Ctrl+A）
  • 剪切：1350（Ctrl+X）
  • 复制：1360（Ctrl+C）
  • 粘贴：1370（Ctrl+V）
  • 删除／删除项目／移除项目：1400（Del）
  • 新建项目：1410（Ctrl+I）
  • 插入项目：1420;
  • 编辑项目：1430;
  • 自动换行：1440;
  • 文字工具：1380;
  • 高亮1：1381;
  • 高亮2：1382;
  • 高亮3：1383;
  • 高亮4：1384;
  • 移除高亮效果：1385;
  • 无序列表1：1386;
  • 无序列表2：1387;
  • 有序列表：1388;
  • 移除列表：1389;
  • 删除空行：1390;
  • 只空一行：1391;
  • 查找／替换：1450（Ctrl+F）
  • 后续查找：1460
  • 查找下一个：1462（F3）
  • 查找上一个：1464（Shift+F3）
  • 替换并查找下一个：1466（F4）
  • 替换并查找上一个：1468（Shift+F4）
  • 全部替换：1470（Ctrl+F4）
  • 高亮查找结果：1480;
  • 插入链接：1490（Ctrl+K）
  • 插入剪贴文字：4000
  • 插入模板文字：5000
  • 后退：1560（Alt+Left）
  • 前进：1570（Alt+Right）
  • 上一层：1580（Alt+U）
  • 最近的笔记：1590;
  • 最近创建：7000;
  • 最近修改：7500;
  • 最近访问：8000;
  • 管理最近的笔记：1600;
  • 收藏夹：6500
  • 添加至收藏夹／从收藏夹移除：1610;
  • 收藏家管理：1620;
  • 搜索：1630（Alt+F）
  • 回收站管理：1650;
  • 显示目录树：1710（Ctrl+T）
  • 总在最前：1720（Ctrl+P）
  • 透明效果：1730（Ctrl+R）
  • 自动隐藏：1740（Ctrl+H）
  • 文字模板管理：1750;
  • 快速链接管理：1760;
  • 剪贴板监视1770;
  • 清空剪贴条目：1780;
  • 剪贴板管理：1790;
  • 统计信息：1800;
  • 自定义工具栏：1810;
  • 选项：1820;
  • 帮助主题：1910（F1）
  • 主页：1920;
  • 论坛：1930;
  • 关于：1940;
  • 捐助：1950;

个别纯使用快捷键、无对应菜单条目的功能 ID 及其默认快捷键列表如下：

  • 上移：1220（Alt+Up）
  • 下移：1230（Alt+Down）
  • 切换焦点：354（Ctrl+Tab)
  • 设为标题：355（F10)
  • 向左隐藏／恢复树窗口：356（Ctrl+Alt+Left)
  • 向右隐藏／恢复树窗口 ：347（Ctrl+Alt+Right)


选项

  1. 程序设置
    1. 编辑设置
    2. 笔记摘录
    3. 导入导出
    4. 操作习惯
    5. 登录设置
    6. 保存与备份
    7. 自动隐藏
  2. 界面设置
    1. 树窗口
    2. 标签栏
    3. 列表窗口
    4. 编辑器
  3. 扩展功能
    1. 计算页
    2. 词典页
    3. 链接页
    4. 文字模板
    5. 多重剪贴板
  4. 未公开的选项


程序设置

随系统自动启动：设置程序是否随 Windows 自动启动。

显示托盘图标：选择是否在系统托盘区显示图标。

最小化到托盘区：设置是否最小化到托盘区（即程序最小化时从任务栏消失）。

启动时最小化：选择是否在启动后立即最小化。

关闭时最小化：设置点击窗体右上角的关闭按钮是否等同于最小化操作。如否，则点击关闭按钮时程序将正常关闭。

自动命名新标签页：选择是否自动命名新建的标签页。当设定为自动命名时，新建笔记页默认按 Note1、Note2... 的形式顺序命名，新建计算页为 Calc1、Calc2...，新建备忘页为 Memo1、Memo2...，新建词典页为 Dict1、Dict2...，新建链接页为 Link1、Link2...，新建通讯页则为 Contact1、Contact2...。使用“重命名”功能可以手动修改其名称。

确认标签删除：设定在删除便笺时是否弹出确认对话框。

外部滚动：设定是否启用外部滚动特性。详见“特色功能”-->“外部滚动”

记忆页面滚动位置：设定是否为各页面记忆滚动位置，在切换到该页面时恢复原来的位置。

切换页面时焦点总在编辑器：如为是，则不管在多页面风格还是树窗口风格下，切换页面后，焦点自动跳到编辑器。

最近的笔记：设定“最近创建”、“最近修改”、“最近访问”列表的最大项目数。

回收站容量：设定回收站中的最大项目数（不包括组下的子节点）。当项目数超过此限制时，较“旧”的项目将会自动清除。

最小化／还原热键：设定最小化／还原切换的全局热键。（使用该热键可在任何场合呼出／最小化minipad2）

邮件客户端：指定用于新建邮件的邮件客户端程序。若留空，则点击“文件”-->“发送邮件”时将调用系统默认的邮件客户端。


编辑设置

自动空行风格：设定编辑区是否为自动空行（即回车后自动添加一空行，每段之间均以空行相隔）风格。

自动缩进风格：设定编辑区是否为自动缩进（即回车后的新行的行首自动与上一行行首对齐）风格。

平滑滚动：设定当使用滚轮卷动页面内容时，是否为平滑滚动风格。

单击打开链接：设定文本中的链接是否使用单击打开（否则则为双击或Ctrl+单击打开）

确认清空操作：设定在清空文字时是否弹出确认对话框。

Tab 宽度：设定按下 Tab 时缩进几个字符。

撤销次数：设定编辑器撤销缓存区的大小（1..32767）。

无序列表 1、2：设定“编辑”-->“文字工具”中的无序列表的符号。


笔记摘录

新建笔记热键：使用该热键以弹出“新建笔记”对话框，输入新的笔记。若当前已选中文字，则新笔记默认以选中文字作为标题。在笔记输入窗口中，可在第一行使用“@xxx”的形式输入标题，随后输入正文。

关闭笔记热键：使用该热键以保存笔记内容并关闭“新建笔记”对话框（相当于点击对话框的关闭按钮）。

后台新建笔记热键：使用该热键以在后台新建一个笔记页。若当前已选中文字，则新笔记默认以选中文字作为标题。

捕捉文字热键：使用该热键以捕捉当前选中文字至 minipad2 的当前笔记页中。

后台新建笔记并捕捉文字热键：使用该热键以在后台新建一个笔记页，并将当前选中文字捕捉到该笔记页中。

捕捉文字并保存为文件热键：使用该热键以打开“保存文件”对话框，将当前所选文字保存到文本文件中。

自动记录开关热键：使用该热键以开启／关闭自动记录功能。


导入导出

当导入时：设定在导入时是弹出导入选项的对话框，还是按照以下的默认设置进行导入。
  导入来源：设定默认的导入来源是从文件，还是从文件夹
  外部存储：若选中该项，则导入的内容仍然保存在源文件中，在 minipad2 中仅新建一个指向该文件的节点链接。否则则将完整内容导入到 minipad2 的数据库中。

当导出时：设定在导出时是弹出导出选项的对话框，还是按照以下的默认设置进行导出。
  编码：设定导出文本文件的编码（支持 Ansi, UTF-8, UTF16LE (Unicode), UTF16BE 四种常见编码）。
  导出方式：设定默认的导出方式（剪贴板，文件，文件夹）。

条目分隔行：设定在将整组内容合并导出到单一的文件时，各子节点内容之间的分隔符（支持文字模板中的各种 转义符）

拖入外部文件时默认为外部存储：设定以文件拖曳的形式导入外部文件时，是否默认为外部存储。（Shift+拖入固定为外部存储，Ctrl+拖入固定为导入内容。直接的拖曳其含义则取决于此处设定。）


操作习惯

Esc 键用于：窗口最小化 ／ 清空文字
设置在按下 Esc 时是主窗口最小化，还是 清空 当前页面的文字。

双击标签页：重命名 ／ 属性切换 ／ 删除
设置在标签页上双击等同于：重命名、或 属性切换、或 删除 当前页面。

中键单击标签页：重命名 ／ 属性切换 ／ 删除
设置中键单击标签页等同于：重命名、或 属性切换、或 删除 当前页面。

双击组的空白处：新建标签页 ／ 回到上一层
设置双击标签栏或组的空白处等同于：新建笔记页，还是 回到上一层。


登录设置

密码登录：设置启动软件时是否要求输入密码。

托盘区锁定：设定当超出一定时间无操作时，自动锁定 minipad2 的托盘图标（此时如重新激活 minipad2，会要求输入密码）。

加密数据文件：设定是否对原始数据文件进行加密。


保存与备份

定时保存：设定是否启用定时保存功能、以及定时保存的时间间隔。

自动备份：设置是否启用自动备份功能、以及每隔多少时间（或多少次保存）做一次备份。

备份数：设置最大备份数。每次备份时软件会自动检查当前的备份数，若已达到或超出最大备份数，则较旧的备份将被自动删除。

备份路径 ：设置备份路径。

详见“特色功能”-->“数据保存与备份”。


自动隐藏

本选项卡针对自动隐藏功能做各种设定。

方向：桌面边缘隐藏的方位。分 左、上、右、下、自由 五种。默认为“自由”，即自动隐藏到最近的桌面边缘。例如窗口原先向右侧隐藏，如拖动窗口到较靠近桌面上侧处，即会自动隐藏在上侧。

回缩延时：设定当鼠标离开窗口后，延迟多少时间回缩隐藏。

弹出延时：设定当鼠标到达窗口所隐藏的桌面边缘时，延迟多少时间窗口弹出。

动画速度：设定窗口回缩／弹出的动画效果速度。

边缘宽度：设定当窗口隐藏在桌面边缘时，外露部分的宽度（像素数）。

详见“特色功能”-->“桌面边缘隐藏”。


界面设置

界面语言：选择软件的界面语言。（在退出选项对话框后生效）

工具窗口风格：选择主窗口是否为工具窗口风格（标题栏仅有关闭按钮，不在任务栏显示）。

标题栏显示标签名：如是，则标题栏文字类如“note1 - minipad2”；否则标题栏仅显示“minipad2”。

显示菜单栏：选择是否显示主菜单栏。

显示工具栏：选择是否显示工具栏。

分隔栏宽度：设置树窗口与编辑区之间的分隔栏（包括其上的小按钮）宽度。

透明等级：设置窗体的透明度（1..10，数字越大透明度越高）。透明／不透明的切换则使用“工具”-->“透明效果”菜单项。

自动调整界面元素：选择在窗口大小改变的情况下是否自动调整界面元素。详见“特色功能”-->“自动调整界面元素”。


树窗口

树窗口：设置树窗口的字体（包括字号、风格、颜色等）与背景色。

树窗口位于右侧：选择树窗口是否显示在编辑区的右侧（默认为显示在左侧）。

树窗口水平滚动条：选择树窗口是否显示水平滚动条。（默认设定下当树窗口内容超出水平边界时会出现水平滚动条）

显示节点按钮：选择树窗口中存在子节点的父节点左侧是否显示 +、- 按钮。

显示节点连线：选择树窗口中各节点之间是否显示连线。

显示节点图标：选择节点是否显示标志页面类型与属性的图标。

根节点以线相连：选择树窗口中根节点处是否以线相连（默认为相连。如去除根节点连线，可以节省左侧空间）。


标签栏

标签栏：设置标签栏的字体（包括字号、风格、颜色等）。

标签栏位于底部：选择标签栏是否位于窗口底部。如否，则标签栏位于顶部。

标签栏多行显示：选择是否以多行形式显示标签栏。

显示标签图标：选择节点是否显示标志页面类型与属性的图标。

高亮当前标签：选择是否高亮显示当前标签。

固定标签宽度：设置标签页的宽度是否为固定值（宽度可设为 1..10），还是随标题长度自动调整。


列表窗口

列表窗口：设置列表窗口的字体（包括字号、风格、颜色等）与背景色。

摘要视图：设置摘要视图的字体（包括字号、风格、颜色等）与背景色。

摘要标题：设置摘要视图标题栏的字体（包括字号、风格、颜色等）与背景色。

当前摘要标题：设置摘要视图中选中项目的标题栏的字体（包括字号、风格、颜色等）与背景色。


编辑器

编辑器：设置编辑器的字体（包括字号、风格、颜色等）与背景色。

页面边距：设定编辑区两侧的页边距（空白宽度）。

显示行号栏：设定是否在编辑区左侧显示行号。行号栏颜色可设定。

高亮显示当前行：设定是否高亮显示当前行。高亮颜色可设定。

文字高亮方案：设置查找结果高亮、以及“文字工具”中的 4 种高亮方式相应的颜色与类别（下划线或背景高亮）。


其他组件

笔记小窗口：设置托盘菜单中“新建笔记”的小窗口的字体（包括字号、风格、颜色等）与背景色。


扩展功能

minipad2 的各项扩展功能类似于插件，可在本选项卡中设定是否启用（即是否在菜单与工具栏中显示相关功能项）。

启用计算页：设置是否使用 计算页 功能。

启用备忘页：设置是否使用 备忘页 功能。

启用词典页：设置是否使用 词典页 功能。

启用链接页：设置是否使用 链接页 功能。

启用通讯页：设置是否使用 通讯页 功能。

启用文字模板：设置是否使用 文字模板 功能。

启用多重剪贴板：设置是否使用 多重剪贴板 功能。

注：对该选项卡所作的各种设置修改，将在重启程序后生效。

关于各项扩展功能的详细介绍，参见“扩展功能”中的相关章节。


计算页

有效小数位数：设定计算结果的有效小数位数（对于大于 1 的数字为小数点后位数，对于小于 1 的纯小数为小数点后第一个非零数字起的小数位数）。设定范围在 0...12 之间。“Float”为不限定小数位数，显示结果与程序代码中的浮点数精度一致。

三角函数计算：弧度制／角度制
设定三角函数中的变量（如 sin(30) 中的 30 ）是代表弧度还是角度。

自定义函数：设定自定义函数列表，每一函数占一行。

参见：“扩展功能”-->“计算页”


词典页

词典列表：管理配置的词典。可选择启用哪些词典、不启用哪些词典及调整各词典的查询次序。

显示多词典检索结果：在配置了多本词典的情况下，是否显示多词典检索结果。(如否，则在词典页中输入单词，按 Enter 后将只显示查到的第一个匹配结果。但按 Shift+Enter 仍可显示多词典查询结果)

屏幕取词：设定屏幕取词的全局热键（在任意软件（编辑器，浏览器...）中选中待查询的单词后，按下该热键，将实时显示查询结果。），以及弹出框的颜色。

参见：“扩展功能”-->“词典页”


链接页

不读取链接图标：对于程序／文件型的链接不单独读取各个链接的图标，而使用统一的图标。这能提高链接页的载入速度（特别对于关联到局域网中其它计算机上的链接而言）

打开链接后自动最小化 minipad2：双击打开链接后，是否自动最小化 minipad2。这对于将 minipad2 作为快启面板使用较有意义。

快速链接热键：设置快速链接弹出菜单的全局热键。

启用子条目热键：设置是否为快速链接的前九个子条目注册全局热键。

参见：“扩展功能”-->“链接页”


文字模板

弹出菜单热键：设定文字模板弹出菜单的全局热键。（使用该热键可在任何 windows 编辑器中呼出文字模板的快捷菜单）

启用子条目热键：设定是否为文字模板的前九个子条目注册全局热键。

捕捉热键：设定用于将当前所选文字“捕捉”（添加）到文字模板列表中的全局热键。

模板／剪贴板弹出菜单无焦点：设定当使用热键呼出弹出菜单时，焦点仍保持在编辑器上，而不切换到弹出菜单上。（2.3/3.0 风格）
优点：可用于在资源管理器中编辑文件名。否则当菜单弹出时由于焦点的切换文件名将不再处于编辑状态。
缺点：由于弹出菜单无焦点，无法用数字键来选择弹出菜单中的前九项；无法用 Esc 取消弹出菜单。
该项设定同时适用于文字模板与剪贴板的弹出菜单。
该项设定默认为不选中，即弹出菜单拥有焦点，可用数字键选择前九项，可用 Esc 取消。

参见：“扩展功能”-->“文字模板”


多重剪贴板

剪贴板条目数：设定剪贴文字列表的最大条目数。（到达该数目后，每捕获一新的剪贴条目，将自动删除一最旧的剪贴条目，以确保总数不变）

条目最大字节数：设定单条剪贴文字的最大字节数。（如复制／剪切操作所涉及的字节数大于此数字，则不加入剪贴列表中）

弹出菜单宽度：设定弹出菜单中每项最多显示的字符数。

过滤重复条目：当捕捉到新的条目时，若该条目相同的内容已存在于剪贴板列表中，则不再重复记录。

仅过滤相邻的重复条目：当捕捉到新的条目时，若当前列表中的第一个条目与此新条目内容相同，则不再重复记录此新条目。

条目粘贴后上浮为第一项：如勾选此项，则每次粘贴某一条目后，该条目自动上浮为第一项。

弹出菜单热键：设定剪贴板弹出菜单的全局热键。（使用该热键可在任何 windows 编辑器中呼出剪贴板快捷菜单）

启用子条目热键：设定是否为剪贴板的前九个子条目注册全局热键。

参见：“扩展功能”-->“多重剪贴板”


未公开的选项

以下选项均为不存在于“选项”对话框中的扩展选项。用户在 关闭 minipad2 的情况下，可自行用记事本等纯文本编辑器打开 minipad2.ini 文件进行设定。

1. 启动页面

默认情况下，minipad2 启动时自动载入前一次关闭时最后浏览的页面。但使用者也可指定 minipad2 启动时载入某一特定页面。方法：

  1. 用记事本等文本编辑器打开 data\minipad2.idx，找到需设为主页的页面所在的一行，记下其 id（该行最左侧的数字）。
  2. 打开 minipad2.ini，找到[Program]-->StartPage 字段，将等号右侧改为上述的 id（如该行不存在，可自行添加）。保存，关闭。

以后每次启动 minipad2，即自动进入该页面。

如希望每次启动时当前页面为根节点“全部”，只需设为 StartPage=0 即可。

2. 定时提醒的默认时间

在创建备忘条目时，默认提醒时间为当前时间的 10 分钟后。如希望修改该选项，可通过修改 ini 文件进行。例如添加如下项目：

[MemoPage]
DefRemindTime=5

默认的提醒时间即改为 5 分钟后。


技巧荟萃

  1. 在编辑器中选中待作为标题的文字，然后按 F10，所选文字将作为当前页的标题。
  2. 按 Ctrl+Tab，可在导航区（树窗口或标签栏）与编辑区（编辑器或列表窗口）之间进行焦点切换。
  3. minipad2 支持节点链接。使用“编辑”-->“插入链接”，选择类别为“节点”，可进行节点链接的插入。某一节点的具体链接路径可在该页的“属性”对话框中进行查看与复制。
  4. 节点链接示例：\Group1\Node1（相当于：全部\Group1\Node1）；..\Node3（同一组下的Node3节点）；@Node3（同一组下的Node3节点）
  5. 在“摘要”视图下，对着待复制的文字按鼠标中键，即可进入文字的选择与复制模式。
  6. 在树窗口与编辑区之间的分隔栏上有个小按钮。无论左击还是右击均为隐藏树窗口，但效果不同。左键单击，编辑区将扩大到原树+编辑区的面积；右键单击，则在隐藏树窗口的同时编辑区面积保持不变。（亦可使用快捷键：Ctrl_Alt_Left, Ctrl_Alt_Right）
  7. 在编辑器按住 Ctrl 键同时滚动鼠标滚轮，可以对编辑区字体进行缩放。按 Ctrl 的同时中键（滚轮）点击，则恢复到缩放前的字体大小。
  8. 按住 Ctrl 的同时点击“新建笔记页”，新节点将插入到当前节点之前。
  9. 若当前节点为组，按住 Shift 的同时点击“新建笔记页”，新建节点将作为该组的平行节点。
  10. 如将某一节点拖曳到某一组之上，默认为将该页作为该组的下属节点。但如拖曳的同时按住 shift 键，则将该节点作为该组的同级节点。如在拖曳的同时按住 Ctrl 键，则为节点复制操作。
  11. Alt+Up, Alt+Down: 用于上、下移动所选项目（当列表窗口处于焦点时。仅支持单选），或在同一层次上向上、向下移动节点（当树窗口处于焦点时）。
  12. 在拖入外部文本文件时按住 Shift，将以外部存储的形式导入文件；Ctrl+拖入则为导入内容。直接的拖曳其含义则取决于“选项”-->“导入导出”中的相关设定（默认为导入内容）。
  13. 在导航树的根路径中，除“全部”外，其他节点（最近的笔记，搜索，收藏夹，回收站...）均可在右键菜单中关闭。关闭后还可通过“导航”菜单下的相关项目再次打开。如需调整各项目的位置，直接拖曳即可。
  14. 在页的属性对话框、以及很多列表项目（联系人，链接...）的编辑对话框中，右上角都有一个小的图标按钮。单击该节点，可以通过选择外部的 ico 文件以改变该项目的图标。右击该节点则恢复到默认图标。
  15. 文字高亮实际上是在所选文字左右各加了一个特征字符。左字符固定为#28，四套方案的右字符分别为#29，#30，#31，#127。这些特征字符在一般的字体下不可见，也无法使用键盘直接输入，但可利用文字模板的 %c(##) 转义符打出。由此借助文字模板可在手不离键盘的情况下使用“打字”或“快捷键”的方式直接进行文字高亮。


关于作者

作者：徐梁

网名：xiaodiega

毕业于：华东理工大学精细化工系

爱好：国学（中医，诗词古文，围棋，民乐...）；欧洲古典音乐

编程技能：Windows SDK 编程；Delphi / PowerBuilder 数据库编程；Html / JavaScript / PHP 网站制作

Email：xiaodiega@gmail.com

我所使用的主要软件：（绝大部分是 Freeware）

  • 杀毒软件：Avast! home
  • 输入法：智能狂拼 2009（双拼 + 偏旁辅助码）
  • 纯文本/网页编辑器：EmEditor
  • 资源管理器：FreeCommander
  • 文件复制增强：TeraCopy
  • 文件搜索增强：Everything
  • 任务栏增强：Taskbar Shuffle
  • 浏览器：Opera；The World
  • 邮件客户端：Foxmail
  • 聊天工具：mirandaIM
  • 点对点下载：eMule
  • FTP 客户端：FFFTP
  • 办公套件：WPS Office 个人版
  • 词典：有道桌面词典
  • PDF 浏览：Foxit Reader
  • PDF 虚拟打印：TinyPDF
  • 图片查看：XnView
  • 抓图工具：FastStone Capture
  • 流程图制作：Diagram Designer
  • 屏幕白板：e-pointer
  • 视频播放器：mplayer WW
  • 音乐播放器：foobar2000; 1by1
  • Flash 播放器：Flash Movie Player
  • 漫画阅读器：MangaMeeya
  • 电子书格式整理：TextEditor（文本整理器 3.0）
  • 视频／音频格式转换：格式工厂
  • MP3 分割：MP3 Splitter
  • 压缩打包：7-Zip
  • 系统清理：CCleaner
  • 磁盘整理：JKDefrag
  • 数据恢复：Recuva
  • 光盘刻录：Prassi ONES
  • 虚拟光驱：WinMount
  • 虚拟硬盘：ramdisk
  • 进程监控：SystemExplorer
  • 硬件与驱动查看：EVEREST Home
  • 主力开发工具：Delphi
  • 资源文件编辑：Resource Workshop；ResEdit
  • UML 绘图：UML Pad
  • 图标编辑: IcoFX
  • 窗口消息跟踪：Spy++
  • 16 进制编辑器：MiniHex
  • 文件比较：CompareIt!
  • 安装程序制作：InnoSetup
  • 帮助文档编译：HTML WorkShop


捐助 minipad2

minipad2 是个免费软件，功能上没有任何限制。然而，为了这一软件的不断更新与完善，作者投入了大量的业余时间，付出了大量的心血，放弃娱乐，放弃休息，甚至小小地牺牲了一点健康，个中酸甜苦乐不足为外人道。

作者承诺这一软件的中文版永久免费，但如果您喜欢这一软件，愿意帮助这一小小软件逐步成长，作者同样欢迎您提供资金上的捐助。捐助金额不限，可通过支付宝、PayPal 或银行转帐的方式进行，具体帐户信息如下：

支付宝：

  • 帐号：xiaodiega@gmail.com
  • 户名：徐梁

PayPal：

  • 帐号：xiaodiega@gmail.com

银行转帐：

  • 开户银行：中国建设银行上海市分行
  • 帐号：1218729980110005485
  • 帐户名：徐梁

捐助用户请给作者发一封 Email，告知您的身份和捐助金额，以便我们知道您的捐助。对于您的帮助，我们不胜感激。

在未来的软件发展中，作者将优先考虑捐助者的意见与建议，优先对捐助者提供技术支持。